Topics

Iambic B Timing of Release Problem Solved - Defaults Should be Changed

Max NG7M
 

Hi Everyone, I decided to do a new topic rather than reply to my previous post where I stated that the default Iambic B mode just wasn't quite right.  What i should have done before posting was to RTFM (read the 'fabulous' manual). :)  Which I now have done.  Plus a little research into the history of Iambic B mode (Curtis B mode as it was originally called).  The issue I had with the Iambic B default / percent based timings on the release of the dah or the dit are due to the fact that the Morserino does not come setup with defaults that match how the original Iambic/Curtis B mode worked.

The original Curtis B / Iambic B mode didn't take a percentage of the release of the dah or dit when considering the completion of the alternate dit or dah.  This was an 'enhanced' Iambic B invention / change that came later.  By default when you get your Morserino up and running and you select Curtis/Iambic B mode, you get the enhanced version settings for Iambic B... 75% additional release time as i understand it for the dah and 25% additional release time for the dit before the extra dit or dah will complete.

The excellent documentation makes it clear that if you want the 'original' Curtis/Iambic B behavior, you need to set CurtisB DahT% to zero and CurtisB DitT% to zero.  

After making this change, everything is working exactly as I would expect for someone that is use to the original Curtis B / Iambic B timings! It was like night and day! Morserino behaves exactly like a WinKeyer now when keying the Iambic 7 characters, R,K,Y,Q,F,L and C!  Just what I was looking for and expecting the first time I keyed my Morserino.

Willi, I would highly recommend that you change the default for the CurtisB DahT%/DitT% to zero in the code.  For anyone using a WinKeyer or trying a Winkeyer after learning on the Morserino (if they are new to Iambic keying), will be very confused and frustrated.  WinKeyer is really the ubiquitous reference for how an Iambic keyer should behave and it doesn't even have the option to change the settings from the original Curtis B timing on the release of the dah or dit.  After all my years using Iambic B for keying, I never even knew there was an 'enhanced Curtis/Iambic B' mode.

With the defaults not matching the original Curtis B mode, I suspect this question will come up over and over again.  It makes much more sense to me to default the Curtis B / Iambic B mode to the original... set the above settings to zero by default.

Thanks for reading and considering the change back to defaults of zero for the above two Curtis B settings.  Morserino being successful is no surprise.   It's an excellent design and has all kinds of potential.  Very cool project and design.  Top notch!

Max NG7M 

jsurls@...
 

Thanks, Max for this details explanation. This is exactly what happened to me.

The past 6 months I've been learning CW on the Morserino. It's been a great tool to use. However when I started using other radios (7300, MTR5B), I would end up sending an extra char for iambic chars. Changing to zero and zero matched on the Morserino what I was experiencing on the other radios. Time to unwind some habits and build other ones instead.

+1 on setting it to 0 and 0 as the default. Would save folks some time and angst wondering what's going on.

Thanks,
-Joey KI5DDO

Martin Hepp
 

On 28. Dec 2019, at 23:07, jsurls@... wrote:

+1 on setting it to 0 and 0 as the default. Would save folks some time and angst wondering what's going on.
+1, too!

73 de Martin, DK3IT

Matthew .
 

Agreed, the timing "feels" better to me this way (CurtisB DahT% to zero and CurtisB DitT% to zero). 

Thanks again for the amazing Morserino, it's a CW game changer!

73
Matt
N2IDW

Willi, OE1WKL
 

I have never got similar feedback before (although the Morserino was used as a keyer at last year’s HSC, e.g.). Can anyone else confirm similar behavior?

73

Willi 

Am 02.02.2020 um 20:40 schrieb Bruce Roberts <Iljbhflm@...>:

When using echo trainer mode at speeds at 25 wpm the Morserino will not correctly decode letters like w, p, j and l. I have verify that my sending is not the issue by using several other programs that decode my sending with out errors. I have tried all of the different iambic settings and nothing seems to solve the problem using firmware v 2.3

Neall
 

I can't confirm. I disagree with the original poster and agree with Willi, from my personal experience only.  I don't see the "original" Mode B used in my keyers.  I have a Pico Keyer II, an Icom IC-7300, a QRP Labs QCX, a Yaesu Ft-450D, a LNR MTR5-B and now the Morserino.  I do NOT have a WinKeyer so can't comment on that.  But the keyers I do have, which I mention here, all DO seem to have a percentage overlap in order to send the offsetting DIT or DAH.   They all seem to be enhanced mode B keyers, in other words.  Someone mentioned they felt the IC-7300 doesn't have that percentage overlap, or the MTR5B and I tend to disagree. I think they do. Or maybe I just adapt to those changes quickly.

I feel the default Mode B iambic settings in the Morserino, with the specified overlaps, very closely approximate the Mode B percentages in my radios and keyers, which all seem to be consistent with Willi's settings.  I go easily between my radios and keyers to the Morserino with the default settings.  I like the default settings.  Again, not meaning to argue with anyone's opinion or individual perceptions.  But I'm happy with the default settings.  73, de W5NED Neall

Neall
 

Seems to me it would be EASIER to accidentally send the wrong ending character by setting defaults to zero, not harder.  73, Neall

Neall
 

I can't send that fast so I can't verify.  Are you talking about decoding or sending?  You mention both.  Still, if what you're saying is a problem with the Morserino, I can't see how it's attributable to the Curtis B release time.  Letters like J and P are not iambic.  L is iambic but doesn't end with a squeeze.   Curtis B settings wouldn't affect sending these letters anyway.  73, Neall

Bruce Roberts
 
Edited

On Mon, Feb 3, 2020 at 04:58 PM, Willi, OE1WKL wrote:
I have never got similar feedback before (although the Morserino was used as a keyer at last year’s HSC, e.g.). Can anyone else confirm similar behavior?
 
73
 
Willi 

Am 02.02.2020 um 20:40 schrieb Bruce Roberts <Iljbhflm@...


 Sorry I kind of jumped the gun. I had only used the Morserino for a few hours and then posted this result. It was my bad sending that was causing the errors, after spending more time using it I am starting to get the hang of it. Thank You for such a great product. There are just so many good features and it is so we'll thought out. I believe every ham who enjoys cw will want to have one or maybe two morserino's Thanks again, I only wish I would have thought of it.  73 Bruce  K6TTT

Ben
 

On Mon, Feb 3, 2020 at 04:58 PM, Willi, OE1WKL wrote:
I have never got similar feedback before (although the Morserino was used as a keyer at last year’s HSC, e.g.). Can anyone else confirm similar behavior?
Yes I can. I'm a beginner and I was playing with the Morserino for some time (weeks/months). Then last January I joined the CWops beginner class and started using my KX2 as code oscillator at 20 wpm. I immediately noticed I had a problem sending some of the characters, even though both devices are in iambic B mode. Looked online and found the solution in setting dit/dah to 0%. I did this, because I want to use the KX2 in the field, when I'm proficient in working CW. I'm also using the Morserino for training words and have an Icom base station. Now I can switch between all transceivers and they work the same way!

Now, I did test the 45%/75% setting this evening again, and I did not have a problem as before! So probably by setting it to 0% and because I'm learning using the KX2, I have learned to send more strict?

So, going from the default Morserino as a beginner and then switching to a 'normal' iambic b mode gives you troubles. But when you are already used to 'normal' iambic B and going to the default Morserino is not giving you troubles, because you are sending more strict than necessary for the 'enhanced' mode?

Hope I'm making sense :)